Fixture builder...mal wieder Prisma Rotation

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Fixture builder...mal wieder Prisma Rotation

      Irgendwie verzweifele ich jedesmal, wenn ich mit dem Fixture Builder arbeiten muss. Ausgabe am Gerät ohne Probleme, aber keine Ergebnisse in der 3D.

      Seit zwei Tagen versuche ich ein Fixture für einen Showtec Club Wash 250 MSD an zu legen. Ich scheitere immer an der Prismarotation sowie am Shutter, welche im Dimmerkanal enthalten ist. Hauptsächlich geht es mir um die 3D Simulation.Habe auch schon andere Fistures angeschaut, Robe Pointe oder alte MAC 250,aber es klappt einfach nicht.

      Woliegt das Problem? Hier zwei Screenshots.


    • Well ... Visualizations in dot2 3D are created from the 'SUBATTRIBUTES' of 'ATTRIBUTES' in the profile and the PHYS FROM and PHYS TO entry fields. There are only a few 'keywords' that function as a SUBATTRIBUTES in dot2 3D and they must be Exactly named, otherwise they will not visualize / render in 3D dot2, but may be the actual fixture on the stage .

      Looking at the image you have provided, I would say why you are not seeing the 'effect'.

      Try changing the name of EFFECTROTATE to "PRISMA1_ROT". This makes PRISMA1 rotate in dot2 3D ...
      The other visualization for the PRISMA1 'effect' is "PRISMA1_POS". This 'should' allow for non-continuous indexing of the effect for alignment.

      I think the visualization you want is PRISMA1_ROT. The keyword of EFFECTROTATE as a sub-attribute is NO visualization that I know of.

      Good luck!
      Rex

      Your SHUTTER issue may be solved with more clear Phys From and Phys To data in the entry fields ... from the information in the image, you are telling the SHUTTER to go from 0 to 10% as DMX goes from 129 to 230. A SHUTTER subattribute should either 0 or 1 , Closed or Open . During the DMX [129-230], change both PHYS FROM and PHYS TO 1 , if the SHUTTER is meant to be CLOSED during DMX [129-230] change both PHYS FROM and PHYS to 0 .

      There are not any in the Fixture Builder about what is an actual 'visualization' subattribute and what does not render in dot2 3D.

      So, your ENCODER ranges are wacky. Within each Channel set, the encoders should be divided into ranges as the DMX values are, unless you want each section to start at zero to each individual end ... never done that before.

      Apologize for strange translating text from what I typed in English ...

      The post was edited 5 times, last by Rex: strange text changes for translation...?!? ().

    • Hey Rex,

      thanx for the answer, but stil no succes. I tried to do a sipmle example. DMX 1-128 = Prism, form DMX 129-255 = Prism rotation.
      Well, in the simulation, the prism is there till DMX 128, then, from 129 to 255 it disappears.

      Even rebuilding the MAC 250 fixture 1 to 1 did not worked out. In the original files it works, in the copy it does ot work.

    • Ich hänge mal das Fixture in den Anhang, vielleicht hat jemand eine Idee.

      Immer noch folgendes Problem:

      Kanal 7 ist Effektkanal mit Prisma, es ist ein kombinierter Kanal mit Prisma Off, Prisma On und Prisma Rotation.
      (Canal 7 is my problem, it is a mixed channel with Prism Off, Prism On and Prism Rotation)
      DMX:0 - Prism Off
      DMX: 1 to128 Prism Rotation >>>
      DMX 129 to 132 STOP
      DMX: 133 to 255 Prism Rotation <<<

      working on stage, but not in 3D

      Second: A mixed Dimmer / Shutter / Reset Channel.
      Channel 4: DMX 0 - 128 Dimmer
      DMX 129-132 Full
      DMX 133 - - 250 Shutter Max. 10 per second Min. 0.3 per second
      DMX 250-251 Reset
      DMX 252-255 Full Dimmer

      Danke!!!
      Files
    • XML Source Code

      1. <ChannelType index = "3" attribute = "SHUTTER" feature = "SHUTTER" preset = "BEAM" coarse = "4">
      2. <ChannelFunction index = "0" from = "0" to = "25" min_dmx_24 = "0" max_dmx_24 = "8750469" physfrom = "0" physto = "1" subattribute = "DIM" attribute = "SHUTTER" feature = " SHUTTER "preset =" BEAM ">
      3. <ChannelSet index = "0" name = "Min" from_dmx = "0" to_dmx = "0" />
      4. <ChannelSet index = "1" name = "Max" from_dmx = "133" to_dmx = "133" />
      5. </ ChannelFunction>
      6. <ChannelFunction index = "2" from = "26" to = "50" min_dmx_24 = "8816262" max_dmx_24 = "15987700" physfrom = "10" physto = "1" subattribute = "STROBE" attribute = "SHUTTER" feature = " SHUTTER "preset =" BEAM ">
      7. <ChannelSet index = "0" name = "FAST" from_dmx = "134" to_dmx = "134" />
      8. <ChannelSet index = "1" name = "SLOW" from_dmx = "243" to_dmx = "243" />
      9. </ ChannelFunction>
      10. <ChannelFunction index = "2" from = "51" to = "75" min_dmx_24 = "16053492" max_dmx_24 = "16382457" physfrom = "0" physto = "1" subattribute = "RESET" attribute = "SHUTTER" feature = " SHUTTER "preset =" BEAM ">
      11. <ChannelSet index = "0" name = "Reset Shutter" from_dmx = "244" to_dmx = "249" />
      12. </ ChannelFunction>
      13. <ChannelFunction index = "3" from = "76" to = "100" min_dmx_24 = "16448250" max_dmx_24 = "16777215" physfrom = "1" physto = "1" subattribute = "SHUTTER" attribute = "SHUTTER" feature = " SHUTTER "preset =" BEAM ">
      14. <ChannelSet index = "0" name = "Open" from_dmx = "250" to_dmx = "255" />
      15. </ ChannelFunction>
      16. </ ChannelType>
      Display All
      This may be how your fixture needs to be set up in the way of a 'SHUTTER / DIM' ......to follow the DMX chart.

      The post was edited 2 times, last by Rex ().

    • Source Code

      1. <Type Presets>
      2. <Color>
      3. 000-007 Open
      4. 008-015 Cherry Blue
      5. 016-023 Pink
      6. 024-031 Green
      7. 032-039 Red
      8. 040-047 Light Blue
      9. 048-055 Yellow
      10. 056-063 Peach Blow
      11. 064-064 Open
      12. 065-125 UV filter
      13. 126-127 Open
      14. 128-191 Slow-Fast> CW
      15. 192-255 Fast-Slow> CCW
      16. </ Color>
      17. <Gobo>
      18. 000-015 Open
      19. 016-031 Gobo 1
      20. 032-047 Gobo 2
      21. 048-063 Gobo 3
      22. 064-079 Gobo 4
      23. 080-095 Gobo 5
      24. 096-111 Gobo 6
      25. 112-127 Gobo 7
      26. 128-191 Slow-Fast> CW
      27. 192-255 Fast-Slow> CCW
      28. </ Gobo>
      29. <Gobo rotation>
      30. 000-015 Still
      31. 016-135 Fast-Slow> CW
      32. 136-255 Slow-Fast> CCW
      33. </ Gobo Rotation>
      34. <Shutter>
      35. 000-133 min Max
      36. 134-243 Fast Slow
      37. 244-249 Reset
      38. 250-255 Open
      39. </ Shutter>
      40. <Pan>
      41. 000-255 CCW CW
      42. </ Pan>
      43. <Tilt>
      44. 000-255 CCW CW
      45. </ Tilt>
      46. <Prism>
      47. 000-000 Open
      48. 001-128 Slow-Fast> CW
      49. 129-133 Still
      50. 134-255 Slow-Fast> CCW
      51. </ Prism>
      52. </ Type Presets>
      Display All
      This seems to be a more accurate DMX chart to build a fixture from...cheers!

      Rex
    • Now it workes!!! Jetzt funktioniert es.
      I did the fixture again, but this time, instead of the Fixture Builder, with MA2onPC.<
      Diesmal mit der MA2onPC Software statt mit dem Fixture Builder.

      Thanx a lot!!!!!


      Short luck. Prism worked,....just reopend it in fixture builder to change the gobo....only the gobos, nothing else no other channel, only he gobo channel...and after saving, the rpism is gone and the shutter is gone. I give up...spend 4 days trying to make the fixture go. It is sooooo frustrating.

      The post was edited 1 time, last by guiri ().

    • Here ya go...give this a try. Very Quick and Dirty.

      Got everything to visualize excepting Prism1_Rot?? Every time I call it up with the console, the multiple beams snap back into a single?!? Tried giving each one it's own Subattribute but no go...

      GoboWheel spins, Gobo1 individuals rotate each direction and stop.

      Shutter works as DMX channels are schedules[DIM first, then Strobe, then the Shutter Open, just need to go to RAW values to fine the SMART BUTTONS...all work with Fader, just all on one handle[the bane of 'split channels' of control].

      Good luck with the PRISM1_ROT Function/Channel Sets!! I'd say you're 90%+ to visualizing the fixture as intended!!! FTW!

      Rexy

      PS: do NOT open this.XML from the console in FixtureBuilder....use the console to edit! <info> has my notes!
      Files

      The post was edited 1 time, last by Rex ().

    • Here's how I 'think' it should be written to visualize... I 'think' why you can't visualize the 'rotation' is because of 2 subattributes on the same attribute? But you can visualize Gobo and GoboWheel Spin within the same attribute, so I got nothing beyond how I 'think' it should work.

      Good luck with rotating prism!

      Rex
      Files
    • Hey Rex, thanks a lot. I know, you did a lot of work!!!!! Very nice work.

      With the Prism spin it is crazy, one time I made it work perfectly in the simulation, but then, after changing gobo numbers to real gobos it disapeared. Got no idea why. The MAC 250 got a mixed Prism channel as well, workes fine in the simulation, but copying the prism code to the showtec does not work.
      Anyway, thanks a lot again!!! Cheers from Spain.