Kein Web Remote möglich

    • Kein Web Remote möglich

      Hallo zusammen,
      ich versuche nun schon seit mehreren Tagen die Web Remote Funktion für das Dot2 onPC hinzubekommen und bin am verzweifeln:
      Es funktioniert bei mir einfach nicht. Immer wenn ich die vorgeschlagene IP-Adresse aus dem onPC in einen Browser eingebe scheint der zwar kurz irgendetwas zu laden, doch bleibt der Bildschirm danach weiß und es wird keine Verbindung aufgebaut (Dot2 onPC zeigt kein aktives Web-Remot-Symbol).
      Ich habe mir alle möglichen Threads hier im Forum und die Bedienungsanleitung mehrmals durchgelesen. Jedoch komme ich einfach nicht drauf, was ich falsch machen könnte.
      Folgendes hab ich in allen möglichen Konstellationen probiert, nachdem der erklärte Weg nie zum Erfolg geführt hat:
      - 2 verschiedene Router
      - Konfiguration mit DHCP und ohne
      - Habe auf 2 verschiedenen Laptops die neueste Softwar-Version installiert und mit beiden ausprobiert
      - 2 verschiedene Tablets
      - Safari, Firefox, Google Chrome auf allen vier Geräte (2x Laptop und 2x Tablet)
      - Manuelle und automatische IP-Adresse
      - Neuinstallation der Software und Neustart der Geräte
      - Mehrfacher Reset und Neukonfiguration der Router
      - Alle möglichen Netzwerkschnittstellen im Programm (Loopback, WLAN, ETHERNET-Port)
      - Mehrfaches Ein- und Ausschalten der Remote-Funktion (im Programm) oder Neustarten

      Eigentlich hätte es irgendwie funktionieren müssen: Habe jedesmal überprüft, ob die IP-Adressen im selben Subnetz liegen und es auch mit manuellen Adressen mehrfach ausprobiert.
      Doch das Web Remote will bei keiner der Konstellationen. Nicht einmal wenn ich das Loopback-Interface aktiv habe und versuche auf dem selben Laptop in einem Browser die Verbindung herzustellen (so wird es ja auch in einigen Videos gezeigt).

      Seltsam finde ich aber auch, dass andere meiner Web-Remote-fähigen Programme ohne Progbleme funktioniern, nur das Dot2 onPC streikt.


      Hat irgendjemand einen Tip, was man sonst noch an den Einstellung auf dem Rechner (Windows 10) vornehmen könnte, um das hinzubekommen?

      Das Dot2 3D läuft mit dem Loopback-Interface übrigens auch problemlos.


      Grüße
      Elias
    • Hallo Elias,

      das klingt wirklich danach, dass du schon sehr sehr viel ausprobiert hast. Drei Anmerkungen fallen mir noch dazu ein:

      - verbindest du beide PCs / Tablets per WLAN? Ich würde empfehlen den onPC per Kabel an den Router anzuschließen und das Tablet dann per WLAN zu verbinden.
      - hast du mal die Firewall und den Devender von Windows zu deaktiveren?
      - hast du mal versucht per PING herauszufinden ob PC und Tablet sich überhaupt im Netzwerk sehen?

      Grüße,
      Lars
      Technical Support
      MA Lighting Int.
    • Hallo zusammen,
      ich habe das Problem gestern in den Griff bekommen!

      Das Problem liegt ganz offensichtlich an der zu verwendenden Port-Nummer der dot2 onPC.
      Für die Kommunikation zwischen dot2 onPC (Server) und anderen Anwendungen (Webbrowser als Clients) muss auf dem PC (auf dem dot2 onPC läuft)
      der Port 80 verwendet werden. Dieser wird beim Start von dot2 onPC automatisch eingerichtet.
      Allerdings können auf diesem PC schon Anwendungen laufen, die den Port 80 bereits benutzen.

      Logische Schlussfolgerung wäre, dass das dot2 onPC eine neue Port-Nummer erhält, die man dann einfach beim Verbindungsaufbau angibt:
      Da man aber nur die IP-Adresse im Webbrowser eingibt, wird der Verbindungsaufbau automatisch über den Port 80 eingerichtet (da ja http-Protokoll).
      Leider ist die dot2 onPC-Software so konfiguriert, dass diese für das Web-Remote ausschließlich über Port 80 kommunizieren kann :(

      Wenn dieser Port aber bereits belegt ist, kann dies dazu führen, dass die Kommunikation über diesen Port von der anderen Anwendung blockiert wird, wie in meinem Fall.

      Einzige Lösung: Man muss die Anwendung, welche Port 80 bereits benutzt identifizieren und beenden. Ich habe im Anhang mal eine entsprechende Fehlerbehandlung für Windows 10 erstellt, falls nochmal jemand ähnlich Probleme hat.


      Bei Fragen, gerne bei mir melden.



      Grüße
      Elias


      P.S.
      Vielleicht könnte man zukünftige Softwareversionen so auslegen, dass die Web-Remote nicht zwanghaft über Port 80 erfolgen muss, sondern dass automatisch eine eigen Port-Nummer zugewiesen wird. Diese sollte man dann ebenfalls neben der IP-Adresse des PCs für die Web-Remote einsehen können, um sie für den Verbinsungsaufbau in einem Webbrowser angeben zu können.
      Files